当前位置:首页 > 问答

通达信赫尔均线公式

我来帮TA回答

求通达信均线粘合公式

你没说要那几条均线粘合,我做了给你5、10、20、30粘合的,粘合度为3个百分点,不懂可以扣我。
公式如下:
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M30:=MA(C,30);
A1:=MAX(M30,MAX(M20,MAX(M5,M10)));
A2:=MIN(M30,MIN(M20,MIN(M5,M10)));
(A1-A2)/A2*100<=3;

修改通达信公式:请大神把下面公式加上均线

{多彩K线-主图公式, 显示大阳\\大阴\\涨停\\跌停\\假阴\\假阳\\跳空\\大K线中点,适用于通达信 }
C_: CONST(C),COLORLIRED,POINTDOT;{现价线}
MA5:=MA(C,5);
MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;
DRAWKLINE(H,O,L,C);{重绘K线}
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大阳线,O,C,1,0),COLOR0000BB;
大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);
STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;
STICKLINE(涨停,O,C,1,0),COLORMAGENTA;
STICKLINE(跌停,O,C,1,0),COLORLICYAN;
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,0,0),COLORRED;{假阴柱};
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,0,0),COLORGREEN;{假阳柱};
大盘TJ:=PERIOD=5 AND NAMELIKE('上证指数')
AND (ABS((C-REF(C,1)))/REF(C,1)>=0.025 OR ABS(C-O)>=60);
STICKLINE(大盘TJ,(H+L)/2,(H+L)/2,2,0),COLORYELLOW;{显示大盘日线的60点大K线中值};
STICKLINE((大阳线 OR 大阴线 OR 涨停 OR 跌停)
AND BETWEEN(C,1,500),L+(H-L)/2,L+(H-L)/2,1,0),COLORYELLOW;{大K线画中点线};
MAA5:MA(C,5);
MAA10:MA(C,10);
MAA20:MA(C,20);
MAA30:MA(C,30);
MAA60:MA(C,60);
MAA120:MA(C,120);

通达信移动平均线公式

cross(c,ma(c,30)) and ma(c,30)>=ref(ma(c,30),1);

通达信选股公式问题(当前股价在任意N条均线之上)

C>MA(C,5) AND C>C>MA(C,7) AND C>C>MA(C,13);
你上面参数设置 MA1 MA2 MA3 想看的时候 随便调那三根都行 C>MA(C,MA1) AND C>MA(C,MA2) AND C>MA(C,MA3) 这样可以弄附图 指标

如何在通达信中设置 神奇均线 (主图指标)?

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
A8: EMA(Var1,2.78)*1.028;
A9: MA(OPEN,3.2)*1.028;
安全线: EMA(CLOSE,55), CIRCLEDOT;

请老师编个主图公式!(均线的)

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
X:=MAX(MA5,MAX(MA10,MA20));
ZRXG:=MA5>MA10 AND MA10>MA20 AND CROSS(C>X,0.5)
AND MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) ;
DRAWICON(CROSS(ZRXG,0.5),L*0.987,1);
=============================================
或者
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
X:=MAX(MA5,MAX(MA10,MA20));
ZRXG:=MA5>MA10 AND MA10>MA20 AND C>X
AND MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) ;
DRAWICON(CROSS(ZRXG,0.5),L*0.987,1);
  • 财惠网
  • 炒股配资网
  • 巨财网
  • 黄金喊单
  • 原油直播室
  • 原油期货网
  • 原油期货
  • 期货直播间
  • 黄金喊单
  • 外盘期货喊单
  • 期货直播室
  • 恒指喊单直播室
  • 期货直播室
  • 薛城财经
  • 国际期货喊单
  • 助腾财经
  • 黄金喊单
  • 中银网
  • 恒指期货直播
  • 美原油直播室
  • 黄金喊单
  • 金融知识科普网
  • 亿森财经
  • >凯贝股票网
  • 财姐网
  • >东台网
  • 广东炒股网